Page 2 of 3

Re: Internal Server Error

PostPosted: Thu Jan 06, 2011 7:26 pm
by runstrails
Sloooooooow for me too. But no server error yet.

Thanks for your efforts eric.

Re: Internal Server Error

PostPosted: Thu Jan 06, 2011 8:47 pm
by erbeeflower
Was good yesterday after 3 very slow days, very slow with internal server errors showing 500? sorry i can't reply to pm's at the moment !

Re: Internal Server Error

PostPosted: Fri Jan 07, 2011 12:59 am
by Webwanderer
Okay, what happened? It's as fast as it was slow. As good as I've ever seen it. :D

WW

Re: Internal Server Error

PostPosted: Fri Jan 07, 2011 1:05 am
by erict
Dear Sir/Madam,
Regarding your hosting account INNER-GROWTH.INFO:
It has come to our attention that your hosting account for INNER-GROWTH.INFO is causing an overload of the shared resources on this server. This, in turn, affects the server performance for other customers. We have migrated your site to a new server to provide you time to resolve the issue.

Unfortunately, we are not able to troubleshoot custom scripting and therefore, we are not able to provide specific solutions.

Additionally, other causes of this issue can include, but are not limited to, non-optimized scripts, high traffic, form spamming, etc.

You will have until February 5, 2011 to resolve the issue at hand.

At the end of this time period, we will review your CPU usage. If it has been resolved, we will migrate you back to the original server. If it has not been resolved, you should then consider the need to upgrade to a Dedicated Server. Please note, if the CPU usage is further exceeded on this new server, we reserve the right to suspend the account to ensure the overall health of the server.

If you have questions about this matter, you may contact us by replying to this email or by calling 480-505-8871.
We appreciate your cooperation in this matter.
Hosting Support Team

Re: Internal Server Error

PostPosted: Fri Jan 07, 2011 1:16 am
by erict
*********************************************************
HOSTING ACCOUNT UPDATE
*********************************************************

Dear Eric ,

As part of a continuing effort to provide the highest quality
service for our valued customers, your hosting account has
been migrated to a new server that will provide you with
increased performance and reliability.

Please note that it can take up to 24 hours from the time the
update was completed for any newly-published content to be
visible on your Web site.


Ok, so they moved it, I hope things will get better now. Please provide feedback.

I really can't believe the forum requires a dedicated server. I wonder if there are forum members or visitors with experience in databases, to help evaluate what's causing the slowness.

Re: Internal Server Error

PostPosted: Fri Jan 07, 2011 1:47 am
by kiki
Wow, what an improvement. No problems at all from my computer.

Re: Internal Server Error

PostPosted: Fri Jan 07, 2011 1:58 am
by Quinn
Hi Eric,
About an hour ago, I got "Forbidden access" when trying to enter the site. But I might have hit it while they were in the moving process. Now everything seems fine.

What is the additional expense of going to a dedicated server?

Why is there custom scripting? What about going to a provider that will supply their own forum scripting and be responsible for maintaining it? You might lose some functions, but it could be worth it.

Re: Internal Server Error

PostPosted: Fri Jan 07, 2011 2:08 am
by erict
The forbidden access error was almost certainly caused by the transfer to a new server they made. If it happens again, please let me know, but I don't think it will.

A dedicated server is at least 8 times more expensive and will require a lot more time. Also, I'm pretty sure that it's not necessary. I'm almost convinced that it's either something with the hosting servers or the forum database, or both. There was no dramatic increase in the forum usage in a long time.

I'm backing up everything, and also trying to figure out how to get specific statistics on the database query times, but no luck so far... :(

Re: Internal Server Error

PostPosted: Fri Jan 07, 2011 2:10 am
by the key master
I think we're approaching light speed!!!

Re: Internal Server Error

PostPosted: Fri Jan 07, 2011 2:26 am
by erict
For me the forum runs very well now. Fast and with no errors. Anyone still experiencing significant slowness and/or errors?

Re: Internal Server Error

PostPosted: Fri Jan 07, 2011 2:46 am
by Natalie
Would deleting the threads or posts with video and audio make a difference? There are lots of links to youtube videos in this forum.

Our IT guy at work is always warning against putting links to videos or mp3 audio on our server. I can ask him tomorrow.

Re: Internal Server Error

PostPosted: Fri Jan 07, 2011 2:50 am
by Quinn
That stinks. Wish I could help, but my knowledge is out of date.

Hopefully, their statistics on the new server will show that this site is not the problem.

Thanks so much for working on it even thought you don't have time!

Re: Internal Server Error

PostPosted: Fri Jan 07, 2011 2:58 am
by erict
Natalie wrote:Would deleting the threads or posts with video and audio make a difference? There are lots of links to youtube videos in this forum.

Our IT guy at work is always warning against putting links to videos or mp3 audio on our server. I can ask him tomorrow.


Nope, it wouldn't help. None of that is actually hosted on the server, so it has no effect on performance.

I posted some questions on the official phpbb support forum, and hopefully they will be able to guide me. In the meanwhile, I'm getting ready to run an update. I'll let you know once I do, so you can keep providing feedback.

Re: Internal Server Error

PostPosted: Fri Jan 07, 2011 5:16 am
by erict
Some of you may have noticed the forum was completely down for a few hours. I was running an update, and it kept failing at a certain step (kept giving me the Internal Server Error), and I had to abort the automatic update and completely reinstall the forum, dropping all the previous files and all the modifications. It is very important that you provide me with feedback regarding any abnormalities with the forum functionality, as well as speed and errors. Of course, any errors you encountered in the past several hours are not relevant, as they were caused by the failed update and the entire reinstall process.

I hope things will improve from now on.

Re: Internal Server Error

PostPosted: Fri Jan 07, 2011 7:22 am
by enigma
I've had all the problems mentioned here for the last 3 or 4 days. Got some kind of invalid file error earlier this afternoon, which may have been when you were having your problems, Eric.

What's odd is that I've been having the same ISE trouble with another forum http://spiritualteachers.proboards.com
They almost seemed to go down and come up at the same time, which made me check to see if they were the same group. We have multiple computers here so I know it's not on my end. As far as I know, there's no connection between phpBB group and Proboards, but maybe you know of one that would put them on the same server.

PS I had errors and slowing as recently as 3 hrs ago (6:30pm West coast time). Seems okay now.